[SOLVED] Can't mount external hard drives
Welcome, Guest.
“Theory and practice sometimes clash. And when that happens, theory loses. Every single time.” ― Linus Torvalds

Author Topic: [SOLVED] Can't mount external hard drives  (Read 898 times)

Offline kc9iid

  • Contributor
  • *******
  • Posts: 49
[SOLVED] Can't mount external hard drives
« on: May 14, 2019, 08:56:29 PM »
Never saw this problem before.  No external hard drives or thumb drives show up in thunar.  Tried installing caja and they show up but i get this error, Error mounting /dev/sdb1 at /run/media/mark/Mine(the name of the drive).  Wrong fs type, bad option, bad superblock on/dev/sdb1, missingcodepage or helper program, or other error.  When I run sudo fdisk -l in the terminal it shows up fine, but when I try to mount it with sudo mount /dev/sdb1 I get this error, mount: /dev/sdb1: can't find in /etc/fstab.  I feel stupid because I must be missing or have forgotten something.  Until I fix it I can't transfer any files onto my new arch  xfce install.  Thanks for any help or suggestions.


Edit:  I noticed in gparted that my two external HD's are both NTFS.  No problem in Ubuntu but I guess Arch doesn't like NTFS?
« Last Edit: May 15, 2019, 12:44:59 PM by farevildee »

Offline fchaos

  • Contributor
  • *******
  • Posts: 976
Re: Can't mount external hard drives
« Reply #1 on: May 14, 2019, 10:06:56 PM »
I'm not sure what the issue is, but it's not because they are NTFS... Arch based distros are fine mounting NTFS drives.

It could be that you shouldn't be mounting to /dev. You might need to use /mnt or perhaps /run/media
the other possible issue is that the drives were not shut down properly under windows. Any drive that needs CHKDSK under windows will fail to mount or operate under Linux, and you can't always count on Linux to fix those errors. Plug the drive into a win box and run CHKDSK then be sure to shut down windows properly so all the files get closed.

Offline Spatry

  • Benevolent Dictator
  • Administrator - Sysop
  • **********
  • Posts: 5602
  • Cup of Linux Founder
    • Cup of Linux
Re: Can't mount external hard drives
« Reply #2 on: May 15, 2019, 06:51:33 AM »
Code: [Select]
mkdir /mnt/drive1
mount /dev/sdc1 /mnt/drive1
cd mnt/drive1
ls -l
Sometimes the OLD way of doing things is the most EFFECTIVE way!
Windows assumes the user is an idiot... Linux DEMANDS Proof!

Offline kc9iid

  • Contributor
  • *******
  • Posts: 49
Re: Can't mount external hard drives
« Reply #3 on: May 15, 2019, 09:09:42 AM »
Well, after some more research, I found that I had to install gvfs, execute the commands Spatry suggested, then start thunar as root and change permissions to read and write because even though I had access to all external drives, was unable to do anything. Thank you everyone for your help.  I would say this issue is Solved but don't know how to mark it as such.


Offline farevildee

  • Tyrannical Rule Enforcer
  • Staff Member
  • ********
  • Posts: 1744
  • Linux is learning and freedom
Re: [SOLVED] Can't mount external hard drives
« Reply #4 on: May 15, 2019, 12:47:14 PM »
marked it solved for you kc so you don't have too worry.  ;)
Friends don't let friends use WIndows or Mac OS.