Why Antergos is not good for my usage. (Rant)
Welcome, Guest.
"When tyranny becomes law, rebellion becomes duty." -Thomas Jefferson

Author Topic: Why Antergos is not good for my usage. (Rant)  (Read 1389 times)

Offline gregorylock

  • Contributor
  • *******
  • Posts: 1178
Why Antergos is not good for my usage. (Rant)
« on: October 14, 2018, 05:56:06 PM »
If anyone remembers me here.  You will probably remember me saying I don't like arch.  I thought maybe antergos would be a good distro for running some niche things I've been wanting to get done.  

Has anyone tried to install antergos to a USB drive?  

Long sigh I think I've come up with several reasons why I think antergos sucks for me.

Before creating the live DVD I checked the hash against the hash they provided on the website.  The download checked out.



1. Didn't work well in my virtual box installation.  When I tried resizing window it would often get stuck in the reduced size and wouldn't come back without restarting.  Probably a guest addition problem.  But I'm too new to this sort of thing to figure that out.


2.  I tried to install it to a USB drive twice on two different USB drives.  It said it needed at least 16 gigs, and choose 32 gig.  It failed both times.


3.  I tried installing it to a laptop hard drive in a dock.  It also failed on that, as well!


4.  Wouldn't connect to my router through the network card , so I had to switch network cards so it would connect.

The information I'm providing here may not be correct since I had to type it up by hand.

Code: [Select]
starting version 239
ERROR: resume: hibernation device 'UUID=1d3b7b94-efb5-45a1-9987-994e6b88a975' not found
ERROR: device: 'UUID=6e0792c6-2cfe-464e-9753-1be89d1a8f20' not found. Skipping fsck.
mount: /new_root: can't find UUID=6e0792c6-2cfe-464e-9753-1de89d1a8f20.
You are now being dropped into an emergency shell.
sh: can't access tty; job control turned off
[rootfs ]#

FSTAB FILE:
Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
#
UUID=92246041-4daf-441c-bad7-23fdd190c9d4 /boot ext4 defaults,relatime,data=ordered 0 0
UUID=6e0792c6-2cfe-464e-9753-1de89d1a8f20 / ext4 defaults,relatime,data=ordered 0 1
UUID=1d3b7b94-efb5-45a1-9987-994e6b88a975 swap swap defaults 0 0


If anything changes I will report back.  :)


UPDATE 10/14/2018 5:53 pm

What I didn't say in the beginning is I wanted my antergos install to be portable.  I just tried plugging the hard drive back into the computer I installed it on and it booted.  Still this is no good too me.

UPDATE 10/14/2018 at 6:10 pm

While I was typing here, I looked over at the computer and the screen went black with only the mouse showing.  I tried moving it around and the desktop wouldn't come back.  So I switched to a different tty, logged in and typed 'poweroff'


UPDATE: 10/14/2018 at 9:14 pm

I'm downloading hackman-linux
URL:  https://sourceforge.net/projects/hackman-linux/

UPDATE 10/14/2018 at 10:30 pm

I was able to double check the error message.  I found one type-o error and corrected it.

UPDATE 10/14/2018 at 10:44 pm

Hackman Linux is downloaded and all hash tags checked out.

Live DVD created.

Booted into it, and had some trouble getting past the login screen.  Had to look at the comments to find the answer.

Hackman doesn't seem to like my one network card.  Rebooted and now getting ready to try the other one.

On the Arch Linux boot screen I see that the "Hardware Information (HDT)" doesn't work.

UPDATE 10/14/2018 at 11:08 pm


Hackman Linux the installer is currently too complicated for my current knowledge.  It is my opinion that due to the installer it is not a good distro for a beginner.  The installer needs to have more explanations.  Or at least a website URL to where a person could go to learn about the options so that He can study up and better understand what on earth He's even selecting.  Because Ubuntu and Ubuntu based distros don't come with an installer with all these detailed options.

UPDATE 10/14/2018 at 11:28 pm


While I wait for the installer for Hackman Linux to complete doing whatever it is doing.  I ran out of time.  I have other work I need to get done for tomorrow.  I'm turning to my linux mint 18.3 xfce machine to do some audio editing and backing up for what I need done for work tomorrow.  Once hackman is done doing whatever it is doing.  I'm going to push the computer back into it's right place and re install the Linux Mint 18.3 xfce hard drive.  I don't know if I'll ever get around to messing with hackman again.  I don't have all day to do research.  I found this video and I do plan on watching it.  It might give me a clue as to what I need to look up in the future.

https://www.youtube.com/watch?v=xE5V1fJ4guk

The main reason why I never tried to install arch the arch way or even attempted to run in any other way, is simply because I don't have the time to learn it.  I would rather run Manjaro instead except my past experience taught me that I can not keep it running.


UPDATE 10/15/2018 at 12:09 am


I let the installer to hackman linux finish and tried to boot it on the computer it was installed on.  It booted!  I shut down and removed the usb stick I installed it on, and then attached it to my laptop.  It also booted it.  I'm currently installing the updates.  I haven't watched the video yet.  I'm currently working on my audio edits.  Anyways I'm not going to use this install because I don't know if I did everything right or not.  But at least I got it to boot.


UPDATE 10/15/2018 at 1:57 am


I got my audio edits done for the night.  I watched the video and I think I picked up a couple of things about the installer.  I still feel like I need to do some more research to better understand some of the options.  Especially the ones dealing with how it reads and writes to the installation media.

This is the first time I've watched Backyard Tech.  I think I kinda like the guy.
Link:  https://www.youtube.com/user/245ajs/videos

UPDATE 10/15/2018 at 2:20 am

I found his second review video. I'm getting things ready to watch it too.

https://www.youtube.com/watch?v=l6jdpUUgQ3U
« Last Edit: October 15, 2018, 02:22:08 AM by gregorylock »
Real Hardware: Linux Mint 20.1 XFCE, PCLinuxOS XFCE
VirtualBox:  ArchLabs

Offline Spatry

  • Benevolent Dictator
  • Administrator - Sysop
  • **********
  • Posts: 5839
  • Cup of Linux Founder
    • Cup of Linux
Re: Why Antergos is not good for my usage. (Rant)
« Reply #1 on: October 15, 2018, 07:46:29 AM »
If you want a tremendous learning experience, nothing beats building Arch the ARCH WAY. I know and understand that time may be an issue for you, and if that is the case, you might consider tabling the Arch beginner guide until you have a weekend to spare to follow it. I can only say that upon building Arch and following the guide, I learned more about computing in a weekend than I learned in YEARS of operating a machine. By using Antergos and other Arch based builds like Hackman, you are cheating yourself out of a learning curve which will give you a better understanding of how things work in a Linux system. I advise building Arch yourself and running (and repairing) it for a few months at least... it gives you a true sense of appreciation for what Manjaro brings to the table.
Windows assumes the user is an idiot... Linux DEMANDS Proof!