Recovery excercise number 5!
Welcome, Guest.
"Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety." -Benjamin Franklin

Author Topic: Recovery excercise number 5!  (Read 1765 times)

Offline CwF

  • Elite Member
  • *****
  • Posts: 473
Recovery excercise number 5!
« on: March 30, 2017, 08:37:11 PM »
Ok, fun one.
Short story: system has been broken for a month according to apt, yet entirely usable. Made a working backup it's needy state, and proceeded to blow it up. It booted in flickering screens, forever, until I started an F1 session and tried lightdm, it fails and is the flasher. Snce apt has been complaing about my hacking allowed what it insisted, apt autoremove insisted on wiping most everything! Sure! The system was installed a year ago as Debian 8.4, randomly upgraded and broken multiple times. It died as Stretch Debian 9 fully 'current' as of yesterday.

Starting point is then a minimal install.
Full F1 cli functionality, almost, no working network since it was not standard.
Startx yields a castrated xfce4 desktop. There are no icons anywhere and the system does recognize any graphic format. No desktop dohickys work or anything draped normally with a theme. Empty buttons, no window decorations, no menu buttons, etc. Just blank areas, that do work, ie close window, and text everywhere. So the terminal works fine, thunar works in an eerie empty text mode. Basically no rendering past text at all. Except the compositor is working!
Interesting! And note, this is fun. No data has been harmed. Source.list has a functional local pool.
So, where would you start?

Post Merge: March 31, 2017, 11:08:08 AM
Well ok then...Nice rainy day today, all else done for the moment, so allow me to continue my torture, er learning...
So, the system got stripped by what factor I still don't know. Reviewing the package list and logs pixbuf was the last to complain. That is related to the missing windowing and no image (jpg, png, etc0 absence. I cli'd my way into some functionality. My pool proved incomplete in a few areas and needed a few files from the jessie archive, I suppose ones that don't yet differ from stretch, don't know yet, I logged them for later review. So I needed those to get the networking working, prior settings  came back to life. Internet comes in eth0 from a dd-wrt router as client, so no config there. So A quick edit to a selections list for dselect reinstalled some stuff and pulled in some fresh stretch files. A review there shows the dead system list had multiple versions of various packages while the new list list these as deinstall or are absent. All of ruby, some python, and parts of gtk are missing in the new list. Still searching for the one package to revive all dependencies? I found my exact issue mention about some google bare VM xfce installs that skip some dependencies, absent menu icons, all graphic rendering missing, etc, just like my limited desktop. It mentions there doing a reinstall of task-xfce-desktop to restore all dependencies. Well, it's installed and a reinstall didn't help, and it mentions this will bring in the full libreoffice package, which it didn't AND I removed all libreoffice  months ago, and it's still gone? Maybe a fraction of my issue.
Do people generally NOT use "apt autoremove"?
That was an empty list, and has already grown to a few dozen packages it would like to remove.

Post Merge: March 31, 2017, 01:26:45 PM
Holy crap...still mostly disabled, the machine can bring up a VM and they work fine in virt-viewer. virt-manager still not working. But here in the VM all is fine! amazing. So this gives a new argument for me on dom0 heft...

Post Merge: April 01, 2017, 10:23:42 AM
Well, I did make some discoveries. It turned out to be fruitful for my know how. Short story, I haven't fixed: it, but simply worked around it finding lots of new perspective.
The issue is actually out there, I find the exact issue, with various solutions that haven't worked. Xfce can run stripped of what we'd consider 'base' functionality. Way back, a mod errors an unrelated synaptic or apt-get operation, user aborts, a round of configuration doesn't happen, and from thereon it cascades dropping whole trees of dependencies...In this case GTK.
The desktop lack any element done through gtk that is not a font. So many programs don't succeed in drawing their first window. However, if all elements are converted to text only, things start working. For example xfce's terminal crashes and disappears with any right click, middle click, menu pick, or c-n-p operation. However, xterm work flawlessly. So, xterm got promoted and I learned it's config and I like it. A handfull of gnome/gtk things work, gparted, galculator, gtkperf got faster...while gnumeric and other more complicated window dressed thing fail to start. Always a gtk or pixbuf error of some kind. Armegatron works! but went haywire and scrambled the video once. Then, reinstalling QT based things all work fine with menu icons and everything, notably keepassx. As mentioned virt-manager doesn't work, all the underlying virsh does. Issues are only with a full screen view, it disappears with an error: GTK:error;/build yada yada...
So I searched for some functionality I was forced to the terminal and mass conversion of the interface to more text based than graphical. I've wanted to explore some interface choice and here is a good chance. So I made some cascading launchers form the xfce panel all in text like I've wondered about for months, all single click control of vm things like start, view, suspend, resume, etc. While VMM is great at what it does, this simplifies it's multiclick actions to a scoll and a click. I don't really want to go without VMM, but this exercise gave me a boatload of new ways to do things simpler. Converting other elements of the UI to text have also giving me insight to things I'd missed. I never realized how many mouse-over popups there were until now. They're everywhere and instant, unlike the default desktop with laggy response that led me to miss them. Thunar with  no icons in list mode is nice, and faster, and easier for my old eyes to decipher. Also, fruits I'll take forward.
Looking back, my now deleted hypervisor based on Xubuntu had the origins of some of the related issues that later came to debian. VMM would crash on c-n-p operations on a regular basis, vm's always safe. Debian never did until my update to par a few months back. Separate issue, Ithink between qemu and qxl, but whatever..
One thing I've never settled in my preference is whether the hypervisor should be highly functional in it's own right or entirely background. This exercise helped me find some middle ground. I think for me having 4 monitors on the host is too convenient in vm flexibility to having a simpler pass through only hypervisor. But I think I could do without the foreground heft of what I had. But no doubt, it can't be this broken...
Typed on my firefox 52 virtual machine on top of a broken hypervisor...

Post Merge: April 01, 2017, 10:39:31 AM
also, forgot to mention, awhile back I posted about my ignorance of how the F1, F2 terminal stuff worked. Seemed like a security issue to me... I now understand that better. With a broken lightdm I learned to use those terminals with startx instead, and found that when on F2 with a user in X, and F1 with root logged on, the user xfce could have issues or lock, like I've seen from time to time, a flip over to the root terminal on F1 could fix it. So I tested, lock the user desktop (easier to do now) and without F1 root already logged on the whole machine appeared locked, clock stops, etc, reboot required. Same intentional user lock scenario with the root logged on and I can then get to it and save the day. It seems the keystrokes alt-ctrl-F1 only work if it was already logged on...

Post Merge: April 01, 2017, 02:03:02 PM
Even MORE! Actually I'm about done. Outside cold work calls...
So I did what I though would be a tactical nuke, and on short: right back where I started. No icons, no window menus on the mentioned stuff. And overall even leaner than too lean..
apt-get remove and purge lightdm xfce4 xorg gtk+2.0 gtk3.0
check cache policy stuff, match the local pool to debian ftp
apt-get install xorg xfce4 xfce4-goodies gksu virt-viewer
lightdm issues returned from the xorg, ya know I could do without it! startx worked fine where I found those last two needed reinstalled, and here I am. no change...apparently I'm done. failed.

Post Merge: April 01, 2017, 02:24:07 PM
Ok, the fix is in. If ayone is reading, advice please:
After that attempted nuke, the dependencies now are clean and if I do the last step 'apt-get install task-xfce-desktop' it's fixed. It brings in the full libreoffice and all of VLC. Both I had removed. I think I'll always want them removed. How do I skip this step?
« Last Edit: April 01, 2017, 02:24:07 PM by CwF »