[SOLVED] Baffled - keyboard functions in VM\\\'s
Welcome, Guest.
"Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety." -Benjamin Franklin

Author Topic: [SOLVED] Baffled - keyboard functions in VM\\\'s  (Read 1861 times)

Offline CwF

  • Elite Member
  • *****
  • Posts: 473
[SOLVED] Baffled - keyboard functions in VM\\\'s
« on: March 16, 2017, 11:10:08 AM »
I struggled with the title?! I have come up with a strange issue with my VM's. The multimedia keys stopped working within the VM's after a large update (600MB) of my 'stretch' hypervisor. This would be the correct function of the mute, vol up, vol down, and calculator keys on many keyboards. They were working and I didn't pay much attention to them since I rarely use them. I simply verified function months back. Working with newer vm versions built on the Q35 rather than the older fx vm bios I noticed they didn't work. I fired up an older vm that I knew worked, and it didn't work either, so not a Q35 issue. I checked, they work in the host. Then I checked various vm's and they all have the correct configuration, but showkey --scancodes shows
Code: [Select]
#showkey --scancodes
press any key (program terminates 10s after last keypress)...
0xe0 0x9c enter?
0xe0 0x21 calculator
0xe0 0xa1
0xe0 0x30 volume up
0xe0 0xb0
0xe0 0x2e volume down
0xe0 0xae
0xe0 0x20 mute
0xe0 0xa0
0xe0 0x5b windows key
0xe0 0xdb
this is the correct response. In any vm only the windows key, sorry = superkey, responds. So, something change in libvirt somewhere and it no longer passes those keys to vm's. I have no idea what changed. I've found no reference to an intentional change, or an option to configure the behavior. I'm LOST!

Post Merge: March 24, 2017, 11:21:22 AM
interesting... I have other issues, I'll work it out later...something in spice also broke, vdagent, cnp, etc. Background vm communication better, foreground worse. I did something wrong...to be continued...

Post Merge: March 30, 2017, 08:09:52 PM
whoohoo - found part of the issue, along with dozen other anomalies stemming from some jessie to stretch changes in some handling of things I modded months ago. It cascaded into full gtk failure.
It blowed up!
Thread elsewhere...
« Last Edit: March 30, 2017, 08:09:52 PM by CwF »