Cup of Linux

Distro-specific Discussion => Debian based => Topic started by: CwF on August 30, 2017, 11:26:24 AM

Title: [SOLVED] Guest networking
Post by: CwF on August 30, 2017, 11:26:24 AM
I'm back again with another puzzler.
A Linux (debian) VM can ping a windows VM. The Linux VM uses gigolo which sees the ip, loads a list of shares, and then can't reach it. I'm baffled. The same gigolo mounts an external box real windows share fine, but not any form within the same host. Any windows VM on the same host sees all other VM's and external machines fine.
I'm leaning towards a authorization password type error but I'm still missing something.
I find googling useless so far, old info, extraneous...
Note the host does not have samba, 9p, spice, or any other file sharing tricks and it can not ping or mount the VM's. By design. Hypervisor not file server....
Any config of windows VM's and external all see each other and simply work.
Any Linux based VM's on the same host and subnet don't work?
I'm still not knowledgeable enough on linux networking to know, but it appears to me that the final click on gigolo to connect goes nowhere, no traffic hits the windows VM, other than a terminal ping.

On edit, it is a W2k issue so if we're out of scope here, thanks for your time!
A quick test, add a share to a XP VM and it mounts fine within the linux VM's.
Only windows VM's can mount the W2k shares, why I don't yet know.
REASON: As a new idea I dug up the W2k stuff, made a W2k Stack of VM's, a backing file if 1.1GB with specific VM's built on it. File server VM's stacked on it with individual on/off = click a button and the shares appear, click again and they're gone = quasi cold storage. Of note is the fact that the W2k is a good margin faster than the XP's. Past smp and  100% idle issues are fixed, terrible video is fixed, trapping the kbm is optional, and one last layer passing an old quadro rocks. And of course infinitely reconfigurable and migrateable without infinite reactivations...I wish I caught this problem earlier, that W2k seems to be unable to serve up a share to linux...?

Post Merge: August 31, 2017, 10:30:33 AM
Well, indeed a general Linux problem and not a W2k issue, so not out of scope...
solution is this;

client lanman auth = yes
client ntlmv2 auth = no

I find this interesting since the Debian in question did not have this file since there is NO Samba installed!!! Evidently the default behavior of gigolo/gvfs does not include ntlm options anywhere in the GUI, and without stating the fact it does reference the config of samba (cheater!). Gigolo references this on every attempt, so after creating the file the next request worked without restarting any other solutions a ntlm switch of some kind is needed in some way for whatever method to talk NT4/2000 speak rather than XP/2003 speak, they are different.
Really, I'd like to dump gigolo.