AMD problem
Welcome, Guest.
We're BACK! Some users will need to upload new avatars to their profile, sorry about that! Registrations are temporarily closed. -Spat

Author Topic: AMD problem  (Read 1161 times)

Offline mitsos1992

  • Jr. Member
  • ***
  • Posts: 25
  • Offensive Security Enthusiast
AMD problem
« on: December 15, 2019, 12:23:53 PM »
Hello dear forum,
I have been a linux poweruser since ubuntu 9. i have tried almost all linux variants, Arch , ubuntu debian , gentoo , even internal variants like zorin mint etc.

i went ahead and bought the following system.
msi x570 a pro
16 gigs of ddr4 ram 3000mhz ( 2 modules )
AMD ryzen 3400g
samsung evo plus 256gbs

the problem is that i have had a very very hard time getting everything to work out of the box even with the most recent bios updates.

Manjaro XFCE : right out of the box green screen, i cannot even debug or enter terminal. the same thing happens with xubuntu.

manjaro Gnome : i can use the interface, everything works like hardware acceleration.
when i installed proton on steam and tried a few titles to work with direct11 to vulkan. i get pixels and eventually freezes until it needs a power button reset.
i verify that gnome ubuntu gives the same results

i have tried to play with this with different kernel versions 4.9 latest stable LTS one.
5.3 and 5.4 still the same issues.

I was running windows 10 without any issue, and i am installing windows 10 again until i find a way to resolve this..

Suggestions ??

Offline Spatry

  • Benevolent Dictator
  • Administrator - Sysop
  • **********
  • Posts: 5582
  • Cup of Linux Founder
    • Cup of Linux
Re: AMD problem
« Reply #1 on: December 15, 2019, 12:46:45 PM »
I did not see any mention of graphics card or whether you tried FREE or NonFree drivers. See if there is a driver specific to your model.

For other peripherals: Maybe try an older LTS kernel 4.14 or 4.19, maybe the hardware is "too new" and kernel devs have not added drivers into the latest kernel builds?

These are the first things which come up at the top of my head but I am sure someone else my throw some ideas into the mix.
Windows assumes the user is an idiot... Linux DEMANDS Proof!

Offline CwF

  • Elite Member
  • *****
  • Posts: 414
Re: AMD problem
« Reply #2 on: December 15, 2019, 02:02:41 PM »
The video is the integrated amd gpu?
Make sure you have the amd firmware installed. Check dmesg for successful firmware loading and error messages.
The colored screen should be on VT7 or 8, so when there, try <Ctrl><Alt><F1> to get to a prompt

Offline mitsos1992

  • Jr. Member
  • ***
  • Posts: 25
  • Offensive Security Enthusiast
Re: AMD problem
« Reply #3 on: December 15, 2019, 04:24:50 PM »
Spat, AMD ryzen 3400g comes with a gpu integrated.
i dont plan on using a dedicated GPU because this gpu can handle skyrim Ultra with mods 60 fps no problem.

as far as i can tell the firm ware comes with kernel. i get picture at least in gnome environment.
i dont like gnome, but i prefer gnome to windows 10. i would hate to go back to windows 10 just because i dont want to RMA an entire amd build for an intel one.