Waterfox, Firefox, and Chromium Selection Bubble Doesn't Show Up.
Welcome, Guest.
The Chatroom is BACK! --Spatry

Author Topic: Waterfox, Firefox, and Chromium Selection Bubble Doesn't Show Up.  (Read 390 times)

Offline gregorylock

  • Contributor
  • *******
  • Posts: 667
  • Country: us
I've ran into something that I've been wanting to ask you about.  This has happened to me on many different websites.  I was wondering if any of you can tell me why.  

As you can see in the screen shots.  There should be a bubble to indicate what your selecting.  For some reason that bubble does not show up on Amazon, some other websites I visit and use, and in this case it doesn't show up on Microsofts website.  

This is a problem I have with Waterfox, Firefox, but not Chromium.

You may need to see the image in full screen.  For that you might need this link.


You are not allowed to view links. Register or Login


Offline Kalthrix

  • Staff Member
  • ********
  • Posts: 1194
  • Country: us
Re: Waterfox, Firefox, and Chromium Selection Bubble Doesn't Show Up.
« Reply #1 on: February 16, 2019, 09:26:00 PM »
Are these all fresh installs? Just curious if there is something going with browser cache. Blocking all 3rd party cookies might do something like this as well. Hard to tell without seeing it in person. Worst-case potentially doing a full browser settings reset in each might restore the radio buttons on the page.

Linked the articles below, although pretty sure you're familiar already with how to do this.

Chromium-
You are not allowed to view links. Register or Login

Firefox (potentially Waterfox if up on Quantum?)-
You are not allowed to view links. Register or Login
You are not allowed to view links. Register or Login

Offline gregorylock

  • Contributor
  • *******
  • Posts: 667
  • Country: us
Re: Waterfox, Firefox, and Chromium Selection Bubble Doesn\'t Show Up.
« Reply #2 on: February 24, 2019, 09:59:02 PM »
I guess I'll haft to rebuild my browser profiles.  What a mess that will be!

Post Merge: February 24, 2019, 11:05:37 PM
I found my problem.  I created this directory and file to fix the dark theme bug in firefox. /chrome/userContent.css.  The contents of this file was on the arch wiki. 

Code: You are not allowed to view links. Register or Login
input:not(.urlbar-input):not(.textbox-input):not(.form-control):not([type='checkbox']) {
    -moz-appearance: none !important;
    background-color: white;
    color: black;
}

#downloads-indicator-counter {
    color: white;
}

textarea {
    -moz-appearance: none !important;
    background-color: white;
    color: black;
}

select {
    -moz-appearance: none !important;
    background-color: white;
    color: black;
}
« Last Edit: February 24, 2019, 11:05:37 PM by gregorylock »

Offline Kalthrix

  • Staff Member
  • ********
  • Posts: 1194
  • Country: us
Re: Waterfox, Firefox, and Chromium Selection Bubble Doesn't Show Up.
« Reply #3 on: March 08, 2019, 11:38:10 AM »
Nice! Glad you were able to get that figured out. Will have to keep that on standby as I can't do without my dark themes and that would definitely be a problem. Eyes can't take any more pure white screens anymore thanks to prior jobs using Windows. Microsoft and their "wonderful" products (Office 2013) and its lack of anything but brightly colored themes and File Explorer (Windows 7/8/8.1/10 (pre-1809) being pure white.

To be fair, my current employer is using Windows 10 Education v1809 so I can yet again enjoy a dark themed desktop at work. Glad because the only alternative was high contrast before which (while less hard on the eyes), is still a bit hard to see.
You are not allowed to view links. Register or Login

Offline Spatry

  • Benevolent Dictator
  • Administrator - Sysop
  • **********
  • Posts: 5411
  • Country: us
  • Cup of Linux Founder
    • Cup of Linux
Re: Waterfox, Firefox, and Chromium Selection Bubble Doesn't Show Up.
« Reply #4 on: March 08, 2019, 12:00:53 PM »
On a sidenote: Arch/Manjaro users can try "shadowfox-updater" to fix dark theme bugs... additionally it allows you to have a dark theme on ALL Firefox internal system (settings) pages.
You are not allowed to view links. Register or Login
Just build shadowfox-updater using your AUR handler of choice then run
Code: You are not allowed to view links. Register or Login
$ shadowfox-updaterselect your profile and choose your options. Apply and then open Firefox and enjoy a nice dark theme EVERYWHERE... IT compliments the "Midnight Lizard" extension nicely!
Windows assumes the user is an idiot... Linux DEMANDS Proof!