Mumble puts ghost icons in toolbar and disrupts shutdown
Welcome, Guest.

Author Topic: Mumble puts ghost icons in toolbar and disrupts shutdown  (Read 338 times)

Offline Detroit_Bad_Boy

  • Full Member
  • ****
  • Posts: 153
  • Country: 00
  • If at first you don't succeed - sudo
Mumble puts ghost icons in toolbar and disrupts shutdown
« on: April 26, 2018, 12:23:20 PM »
I had to uninstall mumble from my laptop due to it leaving ghost icons in the toolbar. Each time I would re-open it another occurrence of a ghost icon would appear. This, in turn, would halt a shutdown due to these icons. I would have to do a manual shutdown and restart to solve the issue.
That is why I uninstalled it
"I'm sorry Dave. I'm afraid I can't do that" - (HAL 9000) 2001: A Space Odyssey

Offline Kalthrix

  • Staff Member
  • ********
  • Posts: 966
  • Country: us
Re: Mumble puts ghost icons in toolbar and disrupts shutdown
« Reply #1 on: April 27, 2018, 07:53:32 AM »
Weird, haven't noticed an issue from my side on Manjaro 17.1.8(XFCE). Which distro and DE are you using? Just so that others that might be using the same can compare. Might help narrow down the cause of the problem.
You are not allowed to view links. Register or Login

Offline Spatry

  • Benevolent Dictator
  • Administrator - Sysop
  • **********
  • Posts: 4548
  • Country: us
  • Cup of Linux Founder
    • Cup of Linux
Re: Mumble puts ghost icons in toolbar and disrupts shutdown
« Reply #2 on: April 27, 2018, 10:41:28 AM »
Hmmm that is odd... When you close mumble it asks if you want to minimize to tray or close. MY suggestion is to try running mumble from the terminal and then see if it reports any errors when the software is closed. Could also be a glitch with your desktop. You are on Manjaro XFCE, correct? Did you change compositor? Did you try disabling the compositor? Are you on FREE or NON-FREE drivers? I cannot think of anything else to throw in the mix... 
"Wipe that NERVOUS expression off of your face, 3PO!" -General Leia Organa SWTLJ

Offline Detroit_Bad_Boy

  • Full Member
  • ****
  • Posts: 153
  • Country: 00
  • If at first you don't succeed - sudo
Re: Mumble puts ghost icons in toolbar and disrupts shutdown
« Reply #3 on: April 27, 2018, 10:44:11 AM »
I am running manjaro 17.1.8 XFCE on a dell E6220 laptop.
I uninstalled it and cleared orphaned files. I'll DL it again and see what happens

Post Merge: April 27, 2018, 11:22:40 AM

You are not allowed to view links. Register or Login
Hmmm that is odd... When you close mumble it asks if you want to minimize to tray or close. MY suggestion is to try running mumble from the terminal and then see if it reports any errors when the software is closed. Could also be a glitch with your desktop. You are on Manjaro XFCE, correct? Did you change compositor? Did you try disabling the compositor? Are you on FREE or NON-FREE drivers? I cannot think of anything else to throw in the mix...

compositor is not changed and it is running. Mumble does not give me the option of minimizing to toolbar. I am on non free drivers. Yes, I am on XFCE. I'll disable the compositor after a re-install of mumble and try it again. I wonder if I should install Compton or not?
« Last Edit: April 27, 2018, 07:12:31 PM by Detroit_Bad_Boy »
"I'm sorry Dave. I'm afraid I can't do that" - (HAL 9000) 2001: A Space Odyssey

Offline Spatry

  • Benevolent Dictator
  • Administrator - Sysop
  • **********
  • Posts: 4548
  • Country: us
  • Cup of Linux Founder
    • Cup of Linux
Re: Mumble puts ghost icons in toolbar and disrupts shutdown
« Reply #4 on: April 28, 2018, 11:47:43 AM »
I use the default compositor which ships with Manjaro XFCE... Your video card driver must be doing something wonky. Look in your settings for Mumble... is it set to minimize to tray?
"Wipe that NERVOUS expression off of your face, 3PO!" -General Leia Organa SWTLJ

Offline Detroit_Bad_Boy

  • Full Member
  • ****
  • Posts: 153
  • Country: 00
  • If at first you don't succeed - sudo
Re: Re: Mumble puts ghost icons in toolbar and disrupts shutdown
« Reply #5 on: April 28, 2018, 12:36:31 PM »
You are not allowed to view links. Register or Login
I use the default compositor which ships with Manjaro XFCE... Your video card driver must be doing something wonky. Look in your settings for Mumble... is it set to minimize to tray?

It is not set to minimize to tray, but yet the icon persisted (sometimes 2 or 3 depending on how many times I accessed it) without any way to get rid of it
"I'm sorry Dave. I'm afraid I can't do that" - (HAL 9000) 2001: A Space Odyssey

Offline Spatry

  • Benevolent Dictator
  • Administrator - Sysop
  • **********
  • Posts: 4548
  • Country: us
  • Cup of Linux Founder
    • Cup of Linux
Re: Mumble puts ghost icons in toolbar and disrupts shutdown
« Reply #6 on: May 01, 2018, 06:32:01 PM »
CONFIRMED! Now it is happening to me... for some reason Mumble refuses to shutdown properly when it is closed. For now, if Mumble is not properly closing you can kill the process by doing the following in your trusty terminal...
Code: You are not allowed to view links. Register or Login
killall mumbleor you can kill the process in a task manager like htop... whichever is easier for you LOL!
"Wipe that NERVOUS expression off of your face, 3PO!" -General Leia Organa SWTLJ